Main Menu

All times are in GMT -8 (DST) :: The time is now 4:10 am.

Login or Register
Create an account and register your LMI products to gain access to useful resources.

Register Account

Login

Sub Menu

Knowledge Base
Article Data
Article Ref
2821-QEYN-1282
Date Created
Tue, 31st May 2011
Date Modified
Fri, 4th Jul 2014

   Minimum version of VC++ for SDK

Question 

What versions of Microsoft Visual C++ are compatible with the Gocator SDK?

Answer 

Sensor Model All
Firmware Version 3.x, 4.x
SDK Version 3.x, 4.x

The SDK is officially tested and fully supported with VC++ 2008.

VC++ 2010 is not officially tested by LMI at this point, but no issues are expected.

For older editions of VC++, the amount of extra effort required to use the SDK will vary, depending on what you are trying to do. For example, if you wish to compile/link your own application written with VC++ 2003/2005 against the Go2 library, that should work without any hassles. But if you wish to rebuild the Go2 library or the sample code LMI provides, you need to create project files compatible with your version of VC++ before recompiling the LMI sources. 

Using versions older than VC++ 2003 will likely require changes to the Go2 source code, and is not recommended by LMI.